Upgrade your Adobe CC 2017 apps

Adobe has informed us we’re no longer licensed to use certain older versions of Adobe CC products. This means you may need to take action on your One Dundee Desktop to ensure compliance.

Which products can’t you use?

The entire Adobe CC (2017 and earlier) suite, excluding Adobe Acrobat.

What do I need to do?

Managed macOS

First remove the non-compliant apps. Uninstallers are available in Self Service for each 2017 app and bundle in the ‘Adobe CC’ category. Then install the compliant 2018 versions from Self Service.

Windows 7 or 10

First remove the non-compliant apps. Go to the Start menu and search for Programs and Features Manager to reach the window in which you uninstall apps. Then install the compliant 2018 versions from Software Centre (use search bar on Windows 10 to find).