Accessing Box via Internet Explorer 9/10

Box discontinued support for Internet Explorer 9 (IE9) & 10 (IE10) last year because Microsoft announced they will no longer release security updates to them.

What impact does this have?
If you try to access Box on either of these unsupported browsers you will see a banner notifying that you are no longer using a supported browser. Your access to Box from IE9/10 will be blocked until you have upgraded to a supported browser.

How do I check what version I have?
To find out what IE version is on your computer, follow this guidance. On-campus University computers have already been upgraded to a more recent, secure version, so no need to worry on that front.

When will this happen?
This will happen early May 2017. It is highly recommended that you upgrade or switch to a Box supported browser. You can find all of the supported browsers at the Box Community page.

If you have any questions, please contact the IT Service Desk via Help4U.